Adobe Lightroom keyboard shortcuts not working – solved!

Working with Lightroom, or other software, and some of the keyboard shortcuts don’t work? There are a few reasons hotkeys won’t work or will only sometimes work. Let’s dig into some solutions.

Step 1

It’s best to start at the beginning when trying to debug a problem. In this case it means double checking that the software settings are configured correctly. In Lightroom there is no built-in way to change the keyboard shortcuts unless you are using a MIDI controller.

If you are using a MIDI controller that uses the MIDI2LR plugin you can check if your custom shortcuts are causing the problem. To do this go to File -> Plug-in Extras -> Options

From the popup menu go to the ‘Other…’ tab and see if your custom shortcuts are set up correctly to map your MIDI device.

If you are not using a Midi Controller then you can check these system settings:

On Windows 10 there is no easy workaround to changing keyboard shortcuts so you’re pretty safe to assume the settings are fine.

On Mac, the operating system has a built in keyboard shortcuts editing function. To do this:

  • Go to Applications -> System Preferences -> Keyboard preferences
  • Then select Shortcuts from the top tab, then App Shortcuts from the left menu
  • If any custom shortcuts are set up Lightroom should appear in the main window
  • Check if these shortcuts are overriding the shortcut that wasn’t working

Step 2:

See if another program is intercepting your keyboard shortcut commands.

It is possible that a different bit of software on your computer is preferentially taking the keyboard shortcuts.

Some of my keyboard shortcuts wouldn’t work, like copy develop settings (ctrl shift C). After much searching, I found my graphics card software was intercepting them.

The hotkeys in AMD Radeon Software had the same shortcut as Lightroom!

To check this, if you have an AMD graphics card, just right click on the desktop and open up “AMD Radeon Software” (or equivalent):

Then head over to the Hotkeys tab and see if the shortcut you are trying to use is being intercepted by the graphics card software.

I have turned off all my AMD hotkeys now so that all of the Adobe Lightroom shortcuts will work in the future. Problem solved!

If that isn’t your problem, then there might be a different program that is interfering. Check any other programs that run in the background and see if they have keyboard shortcuts.

Share This:

How to Copy an iTunes Playlist to Spotify

How to Stop Websites from Asking to Show Notifications on Google Chrome.


1 thought on “Adobe Lightroom keyboard shortcuts not working – solved!”

Leave a Comment